SSC Home Page
Spitzer Science Center
 SSC Home -  Active Mission -  Overview -  IRAC -  IRS -  MIPS -  Data Archive -  Data Analysis & Tools
Knowledgebase
Mac OS X: Upgrading to Spot/Leopard v19.14
Posted by Elena Scire on 08 January 2019 02:15 PM
PLEASE READ THIS ENTIRE ARTICLE BEFORE UPGRADING SPOT/LEOPARD
 
 
Spot and Leopard v19.14 require Java 1.6 and 1.7. They do not work with version 1.8. Having already installed Java 1.8 will not prevent Spot from working. If you are upgrading Spot from an older version or you are installing Spot on a new machine you need to follow these steps.
 
To check which versions of Java are installed run the following on the command line:
/usr/libexec/java_home -V
You will see a result like :
Matching Java Virtual Machines (4):
    1.8.0_202, x86_64:	"Java SE 8" /Library/Java/JavaVirtualMachines/jdk1.8.0_202.jdk/Contents/Home
    1.7.0_80, x86_64:	"Java SE 7"	/Library/Java/JavaVirtualMachines/jdk1.7.0_80.jdk/Contents/Home
    1.6.0_65-b14-468, x86_64:	"Java SE 6"	/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
    1.6.0_65-b14-468, i386:	"Java SE 6"	/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

If you have a "Java SE 6" and "Java SE 7" you are good to go. If you are missing either then download the needed version using the following instructions. You may have to restart Spot/Leopard after completing these steps.
  1. Install Java 1.6
    1. Go to https://support.apple.com/kb/DL1572 and click "Download" to download Java 6
    2. Double click ~/Downloads/javaforosx.dmg and follow the instructions to install Java 6. It will install the 1.6.0.jdk in /Library/Java/JavaVirtualMachines.
  2. Install Java 1.7 (You may see the error message "Cannot launch "spot" No compatible version of Java 1.7* is available" if you need to install Java 1.7)
    1. Download the Java SE Development Kit 7u80 installation from: https://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html
    2. Double click on the download and complete the installation. You may need to create an Oracle account by following the steps on the webpage you are re-directed to.

If you have installed Java 1.7 and you get the error message "No compatible version of Java 1.7* is available." then see the section below.

 


It is recommended that you download a fresh copy of Spot from http://ssc.spitzer.caltech.edu/warmmission/propkit/spot/Spitzer-pride19_14_0-mac.dmg and replace spot.app with it. Then try restarting Spot. Try this before you follow the directions below.
 
If your Spot will not open after an auto-update or if you get either of these two errors
  • No compatible version of Java 1.7* is available.
  • The application Spot cannot be opened. 
you need to follow these directions:
    1. Download JavaApplicationStub from the SSC website at http://ssc.spitzer.caltech.edu/warmmission/propkit/spot/JavaApplicationStub (right click on the link and Save File As)
    2. In Finder browse to your Spot installation (usually at /Applications/Spitzer-pride) and right click on the spot.app icon and select “Show Package Contents”
    3. Navigate to Contents -> MacOS
    4. In the MacOS directory there should just be one file: JavaApplicationStub
    5. Replace JavaApplicationStub with the attached version.
    6. Repeat from step 2 for Leopard (usually at /Applications/Spitzer-pride )
 
Possible problems: Spot or Leopard does not run after replacing JavaApplicationStub
Fix: JavaApplicationStub must be executable.  A user might have to rename the original and then drop a new one in to replace it.
  • Open a terminal window
  • cd to where Spot/Leopard is installed
    • cd /spot-install-dir/spot.app/Contents/MacOS
    • cd /leopard-install-dir/leopard.app/Contents/MacOS
  • chmod +x JavaApplicationStub
 
(1 vote(s))
Helpful
Not helpful

Comments (0)